The Origin Forum
File Exchange
The Origin Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ | Send File to Tech support
Username:
Password:
Save Password
 All Forums
 Origin Forum for Programming
 Forum for Automation Server/COM and LabVIEW
 Originlab won't open via COM server (Matlab)
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic Lock Topic Edit Topic Delete Topic New Topic Reply to Topic

Nimrod2500

1 Posts

Posted - 12/03/2016 :  2:46:37 PM  Show Profile  Edit Topic  Reply with Quote  View user's IP address  Delete Topic
Hello,

I am using Originlab 2016 and Matlab R2013b. I'm trying to use the COM server in order to transfer data from matlab to originlab and plot it there. However, when I use the following commands:
originObj=actxserver('Origin.ApplicationSI');
invoke(originObj, 'Execute', 'doc -mc 1;');
invoke(originObj, 'IsModified', 'false');
invoke(originObj, 'Load', 'filename');
where 'filename' is the path and file name my origin project is saved to which I want to write, originlab won't open at all. Needless to say that these commands are the commands given in the sample files and they don't run as well.

I'd appreciate some help.
Thanks.

DanielUsingOrigin

1 Posts

Posted - 04/13/2017 :  1:46:02 PM  Show Profile  Edit Reply  Reply with Quote  View user's IP address  Delete Reply
Hi,

I got similar problem with Origin8/MATLAB R2015b and got it fixed (Don't know why)

Below are what I did:
1. Open cmd as Administrator
2. cd to your folder that contains Origin8.exe
3. Type command: Origin8 -regserver
4. Origin will be opened by the command in 3.
5. Go back to MATLAB, run the commands again.
6. Try change 'Origin.ApplicationSI' to 'Origin.Application'

Good Luck with it!!

Daniel
Go to Top of Page
  Previous Topic Topic Next Topic Lock Topic Edit Topic Delete Topic New Topic Reply to Topic
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
The Origin Forum © 2008 Originlab Corporation Go To Top Of Page
Snitz Forums 2000